Browse Source

increasing minimum PHP version to 5.5 as this is required by the yzalis/identicon library upgrade to version 1.2.0

El RIDO 5 months ago
parent
commit
4d6897f063
4 changed files with 3 additions and 4 deletions
  1. 0 1
      .travis.yml
  2. 1 1
      INSTALL.md
  3. 1 1
      composer.json
  4. 1 1
      lib/Controller.php

+ 0 - 1
.travis.yml

@@ -1,7 +1,6 @@
 language: php
 sudo: false
 php:
-  - '5.4'
   - '5.5'
   - '5.6'
   - '7.0'

+ 1 - 1
INSTALL.md

@@ -11,7 +11,7 @@ options](#configuration) to adjust as you see fit.
 
 ### Minimal requirements
 
-- PHP version 5.4 or above
+- PHP version 5.5 or above
 - _one_ of the following sources of cryptographically safe randomness is required:
   - PHP 7 or higher
   - [Libsodium](https://download.libsodium.org/libsodium/content/installation/) and it's [PHP extension](https://paragonie.com/book/pecl-libsodium/read/00-intro.md#installing-libsodium)

+ 1 - 1
composer.json

@@ -24,7 +24,7 @@
 		"docs" : "https://privatebin.info/codedoc/"
 	},
 	"require" : {
-		"php" : "^5.4.0 || ^7.0",
+		"php" : "^5.5.0 || ^7.0",
 		"paragonie/random_compat" : "2.0.18",
 		"yzalis/identicon" : "1.2.0"
 	},

+ 1 - 1
lib/Controller.php

@@ -35,7 +35,7 @@ class Controller
      *
      * @const string
      */
-    const MIN_PHP_VERSION = '5.4.0';
+    const MIN_PHP_VERSION = '5.5.0';
 
     /**
      * show the same error message if the paste expired or does not exist