Browse Source

chore: upgrade rollup and fix warning

Add [exports](https://rollupjs.org/guide/en/#outputexports) to configuration.
Kiro Risk 9 months ago
parent
commit
a54f5fea09
3 changed files with 7 additions and 6 deletions
  1. 1 1
      package.json
  2. 2 1
      scripts/configs.js
  3. 4 4
      yarn.lock

+ 1 - 1
package.json

@@ -83,7 +83,7 @@
     "prettier": "2.4.1",
     "replace-in-file": "^6.1.0",
     "rimraf": "3.0.2",
-    "rollup": "2.60.0",
+    "rollup": "^2.61.1",
     "rollup-plugin-copy": "3.4.0",
     "standard-version": "^9.3.2",
     "terser-webpack-plugin": "5.2.5",

+ 2 - 1
scripts/configs.js

@@ -156,7 +156,8 @@ function genConfig(options) {
       banner,
       file: options.dest,
       format: options.format,
-      name: 'Fuse'
+      name: 'Fuse',
+      exports: 'default'
     }
   }
 

+ 4 - 4
yarn.lock

@@ -9807,10 +9807,10 @@ rollup-plugin-copy@3.4.0:
     globby "10.0.1"
     is-plain-object "^3.0.0"
 
-rollup@2.60.0:
-  version "2.60.0"
-  resolved "https://registry.yarnpkg.com/rollup/-/rollup-2.60.0.tgz#4ee60ab7bdd0356763f87d7099f413e5460fc193"
-  integrity sha512-cHdv9GWd58v58rdseC8e8XIaPUo8a9cgZpnCMMDGZFDZKEODOiPPEQFXLriWr/TjXzhPPmG5bkAztPsOARIcGQ==
+rollup@^2.61.1:
+  version "2.61.1"
+  resolved "https://registry.yarnpkg.com/rollup/-/rollup-2.61.1.tgz#1a5491f84543cf9e4caf6c61222d9a3f8f2ba454"
+  integrity sha512-BbTXlEvB8d+XFbK/7E5doIcRtxWPRiqr0eb5vQ0+2paMM04Ye4PZY5nHOQef2ix24l/L0SpLd5hwcH15QHPdvA==
   optionalDependencies:
     fsevents "~2.3.2"